Silverlight.js под Firefox 3

При приложение, което използва Silverlight 1.0 (Silverlight.js) под Firefox 3 се стига до неприятния момент винаги да показва, че Silverlight не е инсталиран и трябва да се изтегли наново.
Разбира се, повторното изтегляне и инсталиране не води до абсолютно никакъв резултат (освен загубено време).
Проблемът се оказа, че “стария” Silverlight 1.0 няма понятие за Firefox 3 като browser, поради което винаги се изкарва съобщение, че е нужна повторна инсталация.

Решението и причините са описани тук, като общо взето всичко се свежда до подмяна на Silverlight.js файла с по-нова версия (такава от 2.0), която може да се изтегли от http://code.msdn.microsoft.com/silverlightjs

Като цяло, не виждам причина да се използва Silverlight 1.0 за ново RIA приложение, при положение че Silverlight 2 е с много повече възможности и превъзхожда 1.0 в почти всяко едно направление. Но при наличие на неработещо 1.0 приложение, което трябва да се подкара, горното е повече от добре дошло.

Leave a Reply

Your email address will not be published. Required fields are marked *